The Main Toolbar

The Main Toolbar is located at the top of the Authoring Stage.

Main Toolbar

It contains the Page Navigator, the save, preview, copy and paste, copy and paste coordinates, undo, redo, and delete icons as well as the Text Toolbar controls and the hyperlink icon.

File Menu

From the File menu you can do the following things:

Saving a lesson

To save a lesson from the Authoring Stage:

  1. Click File.
  2. Select Save.
    -or-
  3. Click the Save icon.
    -or-
  4. If you close a lesson without saving it, you will be prompted to save it.
  5. Click Yes to save the lesson.

SmartBuilder will Autosave your lesson based on the system settings (default 30 minutes).  When opening a lesson, if an autosave is the latest saved version, you will be prompted which version you want to open.

 

Saving a copy of a lesson

To save a lesson as a copy from the Authoring Stage:

  1. Click File.
  2. Select Save As.
  3. Enter the name of the new lesson and any Meta-data.
  4. Click OK.

The current lesson becomes the newly created copy, and the original is left as the last saved version.

You must open a Work In Progress lesson in order to save a copy.

You can create copies of published lessons without opening them, by clicking Manage and choosing Save As.

Saving a page as template

Saving as a template will save the current page as a template in your Work In Progress > Template folder.

  1. On the Authoring Stage, prepare the contents of your page to be exactly as you want the template to be.
  2. Click File.
  3. Select Save As Template.
  4. Enter the meta-data for the template as necessary.
  5. Click OK.
  6. Close your lesson.
  7. Find the Template in your Work in Progress > Templates folder.
  8. Open the template and clean it out (see tips below).
  9. File > Save and Publish your template.  It will now move to your Published > Templates folder.
  10. Apply the template following these directions.

Tips:

  • Templates can only be one page in size, so if you want to templatize a multi-page lesson, consider making a template for each page within the lesson, and using a naming scheme to suggest using them together (for example, Multiple choice quiz page 1 of 3, Multiple choice quiz page 2 of 3, etc).
  • It is highly recommended that you take the extra time before creating a template to rename all objects logically so that someone less familiar with the interaction can make sense of the objects present.
  • Be explicit with your objects on the page. (For instance, rather than leaving a text object saying "Text object 6" edit the text to be "Caption for intro picture text" so that way the guess work is taken out of what you intended to do with your objects on the page.
  • Always check your Variables panel.  All Global Variables will come with your lesson, even if they are not currently being used on the page.  It's a good idea to clean out (delete) any extra Global Variables so they do not pollute the lesson you are going to apply the Tempalte to.

Previewing a lesson from the Authoring Stage

  1. Click File.
  2. Select Preview.
    -or-
    Click the Preview icon.
  3. When finished previewing, click the X button or the Close button to close the Preview window.

You can also take a Snapshot of your lesson for use in the Details Pane.

Publishing a lesson

To publish a lesson from the Authoring Stage:

  1. Click File.
  2. Select Publish.
  3. Enter any version comments.
  4. Click OK.

This will create a new published version of the lesson in the Published > Lessons folder.

 

Open the Translate window

To open the translate page from the Authoring Stage:

  1. Click File.
  2. Choose Translate.

This will open the Translate window.  Read more about Translation here.

Close a lesson

You can close the lesson that is currently open by:

  1. Clicking File.
  2. Choosing Close.
    -or-
  3. Clicking on the X button located on the lesson tab.

If you haven't saved your lesson, you will be prompted to do so.

Copy and Paste Objects

1. Select the object you want to copy.

2. Click Copy copy icon or press <ctrl + C> on your keyboard.

3. Click Paste paste icon or press <ctrl + V> on your keyboard.

4. Your last 10 items will remain in your Paste Queue.  Use the drop down arrow to the right of the Paste icon to view your Paste Queue.

paste queue

Copy and Paste Object Coordinates

1. Select the object whose coordinates you want to copy.

2. Click the Copy Coordinates copy coordinates iconbutton.

3. Select the object which you want to paste to those coordinates.

4. Click the Paste Coordinates paste coordinates icon button.

Delete Objects From the Page

1. Select the item to be deleted.

2. Click the Delete delete icon button or press the <delete> key on your keyboard.

Hyperlinks

hyperlink  

Hyperlinks can be used to link to an asset, to an external URL, to another page, or to trigger an internal event.

Hyperlinks can be applied to the following objects:

  • Text (as a whole, or just selected portions)
  • Hotspots
  • Buttons
  • Shapes
  • Graphics
  • Streaming SWFs

The Hyperlink Icon is located up near the Text toolbar.

Edit Menu

From the Edit menu you can do the following things:

Apply a Template

  1. Click Edit in the main toolbar.
  2. Select Apply Template.
  3. Select the appropriate template from the template folders in the tree on the left.

You can also apply a template from the Templates panel.

Copy and Paste Pages between Lessons

  1. Click Edit in the Main toobar.
  2. Select Page Sequence.
  3. Select the page(s) you want to copy.
  4. Click the copy button.
  5. Click OK or Cancel.
  6. Close the lesson.
  7. Open the target lesson.
  8. Click Edit in the Main toobar.
  9. Select Page Sequence.
  10. Select the page after which you want to add the copied page(s).
  11. Click the paste button.

 

Delete a Page

To delete a page:

  1. Go to a different page.  If you want to delete Page 4, you cannot have Page 4 open.  Simply move to a different page and then follow the rest of the steps.
  2. Open the Page Sequencer
  3. Select the page(s) you want and then use the Delete button in the top toolbar.
    delete the page
  4. Click OK in the warning prompt, and OK in the Page Sequencer to accept the changes.

 

 

Edit Meta-Data

To edit the meta-data of a lesson from the Edit menu, click Edit in the Main toolbar.  Then, select Meta-data.  From the resulting Edit Meta-data window, change the information about your lesson as needed (for example, rename your lesson).

However, this is not the only way to open the Meta-data window.

Re-Order Pages in a Lesson

  1. Click Edit in the Main toobar.
  2. Select Page Sequence.
  3. Select the page which you want to move.
  4. Click the Move Up  or Move Down  button respectively.
  5. Repeat steps 4 and 5 as necessary to re-order other pages.
  6. Click OK.

You can also copy , paste , add , and delete  pages from the lesson from the Page Sequence window.

Setting the Page Size

The page size determines the dimensions of the lesson, and the way it will be scaled.

It can be accessed from the Edit menu.

You can specify the size of the page in the Page size drop down.  You can also specify a custom page size and enter in the Page width and Page hieght fields directly.

The page size can be fixed, scaled proportionally, or it can be set to stretch to fit the screen.

Using the Grid

The Grid allows you to quickly and easily align objects by providing a visual cue by which you can measure the spatial relationship of objects and the page.


The Grid in use.

You can set the size, choose the color, set the visibility, and turn on or off snapping.

Snapping will make objects only move to vertexes of the Grid, which makes aligning objects easier.

Note: when using the Grid, holding down the <Control> key while using the arrows will allow you to move objects one pixel at a time.

Tips for using the Grid:

  • Vary the size of the grid depending on your work task.
  • Speed up creation time by using the snapping feature.
  • Plan object layout with page measurements.

 

Keyboard shortcuts

Here is a list of all the Keyboard Shortcuts that you can use while on the SmartBuilder Authoring Stage:

  Command   Description
  Ctrl + Z   Undo
  Ctrl + Y   Redo
  Ctrl + X   Cut
  Ctrl + C   Copy
  Ctrl + V   Paste
  Ctrl + A   Select all
  Ctrl + Arrows   Move object one pixel at a time
  Alt while Dragging    Duplicate object
  Shift + Left arrow    (While in a Display) go to previous Display   
  Shift + Right arrow    (While in a Display) go to next Display 

Page Navigator

Main Toolbar

The Page Navigator contains a drop down list with all the pages in the lesson, and the Master Page.  Clicking on a page will take you there.

It also contains arrows that will take you to the next and previous pages.

In addition, it has an Insert Page button that will create a new page after the current page.

You can also create new pages from the Page Sequence window.

Text Toolbar

 

The Text Toolbar can be used to format the style of text on the following objects:

  • Text
  • Input Text
  • Buttons
  • Checkbox Groups
  • Radio Buttons
  • Drop Down Lists
  • Timers
  • Percent Trackers

You can change the following features:

      Fonts

      SmartBuilder can use Embedded fonts and Device fonts.

      Embedded fonts are packaged with the lesson and any learner can view them, regardless of what fonts they have installed on their computer.  Device fonts need to be installed on a learner's machine in order for them to see the font.  This is useful if the font is prevalent, or if you are using doublebyte characters (such as Chinese or Japanese) and want to add ~15mb to your lesson size.  When selecting a font, the Embedded fonts are at the top of the list.